package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\:\/\/[\w\.]+(?:\:?\d{0,5})|(?:mailto|)\:[\w\.]+\@[\w\.]+`)
var str = `http://www.site1.com/perma/doom-rock.htm
http://www.site2.net/mod/doom.html
https://www.site3.com/m/doom-rock
http://site4.com/doom
https://site5.com/doom`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}