import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\\:\\/\\/[\\w\\.]+(?:\\:?\\d{0,5})|(?:mailto|)\\:[\\w\\.]+\\@[\\w\\.]+";
final String string = "http://www.site1.com/perma/doom-rock.htm\n"
+ "http://www.site2.net/mod/doom.html\n"
+ "https://www.site3.com/m/doom-rock\n"
+ "http://site4.com/doom\n"
+ "https://site5.com/doom";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}