const regex = /(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\:\/\/[\w\.]+(?:\:?\d{0,5})|(?:mailto|)\:[\w\.]+\@[\w\.]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:vnc|s3|ssh|scp|sftp|ftp|http|https)\\:\\\/\\\/[\\w\\.]+(?:\\:?\\d{0,5})|(?:mailto|)\\:[\\w\\.]+\\@[\\w\\.]+', 'g')
const str = `http://www.site1.com/perma/doom-rock.htm
http://www.site2.net/mod/doom.html
https://www.site3.com/m/doom-rock
http://site4.com/doom
https://site5.com/doom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}