using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?<arguments>(([^\(\)']*)|(\([^\(\)']*\))|'(.*?)')*)\)";
string input = @"Find arguments inside balanced parenthesis.
Regex idea from Marco https://stackoverflow.com/a/10596403/1898524
( arg1, arg2, arg3, (arg4), '(pip' )
trim(( arg1, arg2, arg2a, arg3, (arg4), '(pip' ))
SELECT ISNULL(string, left(1,13) )
SELECT ISNULL(string,'x' )
SELECT ISNULL(string, char(13) )
SELECT ISNULL(string, char(13) ), ISNULL(string, 'x' )
ISNULL( x )
ISNULL( char(13))
SELECT MID(LTRIM(RTRIM(ISNULL(string, char(13)))),4,8) <-- Does not work on a heavily nested function.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}