package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?<arguments>(([^\(\)']*)|(\([^\(\)']*\))|'(.*?)')*)\)`)
var str = `Find arguments inside balanced parenthesis.
Regex idea from Marco https://stackoverflow.com/a/10596403/1898524
( arg1, arg2, arg3, (arg4), '(pip' )
trim(( arg1, arg2, arg2a, arg3, (arg4), '(pip' ))
SELECT ISNULL(string, left(1,13) )
SELECT ISNULL(string,'x' )
SELECT ISNULL(string, char(13) )
SELECT ISNULL(string, char(13) ), ISNULL(string, 'x' )
ISNULL( x )
ISNULL( char(13))
SELECT MID(LTRIM(RTRIM(ISNULL(string, char(13)))),4,8) <-- Does not work on a heavily nested function.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}