import Foundation
let pattern = #"\((?<arguments>(([^\(\)']*)|(\([^\(\)']*\))|'(.*?)')*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Find arguments inside balanced parenthesis.
Regex idea from Marco https://stackoverflow.com/a/10596403/1898524
( arg1, arg2, arg3, (arg4), '(pip' )
trim(( arg1, arg2, arg2a, arg3, (arg4), '(pip' ))
SELECT ISNULL(string, left(1,13) )
SELECT ISNULL(string,'x' )
SELECT ISNULL(string, char(13) )
SELECT ISNULL(string, char(13) ), ISNULL(string, 'x' )
ISNULL( x )
ISNULL( char(13))
SELECT MID(LTRIM(RTRIM(ISNULL(string, char(13)))),4,8) <-- Does not work on a heavily nested function.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)