using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/[a-z0-9]+(?:[-.][a-z0-9]+)*(?::[0-9]{1,5})?(?:\/[^\/\r\n]+)*\.[a-z]{2,5}(?:[?#]\S*)?$";
string input = @"https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com
https://google.com
http\\www.google.com
http:\\www.google.com
http:\\www.google.com
http://computerName/abc/MenuItems.aspx
https://computerName/abc/MenuItems.aspx
http://www.a.com/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
https://ac/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx
http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://ac/abc/ms.aspx?Id=13
http://ac/abc/ms.aspx
http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
http://www.a.com/ab_c/ms.aspx";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}