import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/[a-z0-9]+(?:[-.][a-z0-9]+)*(?::[0-9]{1,5})?(?:\\/[^\\/\\r\\n]+)*\\.[a-z]{2,5}(?:[?#]\\S*)?$";
final String string = "https://www.google.com\n"
+ "http://www.google.com\n"
+ "www.google.com\n"
+ "htt://www.google.com\n"
+ "://www.google.com\n"
+ "https://google.com\n"
+ "http\\\\www.google.com\n"
+ "http:\\\\www.google.com\n"
+ "http:\\\\www.google.com\n"
+ "http://computerName/abc/MenuItems.aspx\n"
+ "https://computerName/abc/MenuItems.aspx\n"
+ "http://www.a.com/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
+ "http://www.a.com/abc/ms.aspx?Id=13\n\n"
+ "https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
+ "https://ac/abc/ms.aspx?Id=13\n"
+ "https://ac/abc/ms.aspx\n"
+ "http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
+ "http://ac/abc/ms.aspx?Id=13\n"
+ "http://ac/abc/ms.aspx\n"
+ "http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
+ "http://www.a.com/abc/ms.aspx?Id=13\n"
+ "http://www.a.com/ab_c/ms.aspx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}