# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?:\/\/[a-z0-9]+(?:[-.][a-z0-9]+)*(?::[0-9]{1,5})?(?:\/[^\/\r\n]+)*\.[a-z]{2,5}(?:[?#]\S*)?$"
test_str = ("https://www.google.com\n"
"http://www.google.com\n"
"www.google.com\n"
"htt://www.google.com\n"
"://www.google.com\n"
"https://google.com\n"
"http\\\\www.google.com\n"
"http:\\\\www.google.com\n"
"http:\\\\www.google.com\n"
"http://computerName/abc/MenuItems.aspx\n"
"https://computerName/abc/MenuItems.aspx\n"
"http://www.a.com/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
"http://www.a.com/abc/ms.aspx?Id=13\n\n"
"https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
"https://ac/abc/ms.aspx?Id=13\n"
"https://ac/abc/ms.aspx\n"
"http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
"http://ac/abc/ms.aspx?Id=13\n"
"http://ac/abc/ms.aspx\n"
"http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=\n"
"http://www.a.com/abc/ms.aspx?Id=13\n"
"http://www.a.com/ab_c/ms.aspx")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.