re = /^https?:\/\/[a-z0-9]+(?:[-.][a-z0-9]+)*(?::[0-9]{1,5})?(?:\/[^\/\r\n]+)*\.[a-z]{2,5}(?:[?#]\S*)?$/mi
str = 'https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com
https://google.com
http\\\\www.google.com
http:\\\\www.google.com
http:\\\\www.google.com
http://computerName/abc/MenuItems.aspx
https://computerName/abc/MenuItems.aspx
http://www.a.com/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
https://ac/abc/ms.aspx?Id=13
https://ac/abc/ms.aspx
http://ac/abc/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://ac/abc/ms.aspx?Id=13
http://ac/abc/ms.aspx
http://www.a.com/ab_c/ms.aspx?Id=13&(Not.Licensed.For.Production)=
http://www.a.com/abc/ms.aspx?Id=13
http://www.a.com/ab_c/ms.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end