import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^pub\\s+(\\S+)\\s+(\\S+)\\s+.*\\s+.{0,32}(.*)\\s+(.*)<(\\S+)>";
final String string = "pub dsa1024 2018-02-28 [SCA]\n"
+ " 0019003A003E5A22E2337044D955066111F63B00\n"
+ "uid [ unknown] John Doe <jogn@doe.name>\n"
+ "sub elg1024 2018-02-28 [E]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}