const regex = /^pub\s+(\S+)\s+(\S+)\s+.*\s+.{0,32}(.*)\s+(.*)<(\S+)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^pub\\s+(\\S+)\\s+(\\S+)\\s+.*\\s+.{0,32}(.*)\\s+(.*)<(\\S+)>', '')
const str = `pub dsa1024 2018-02-28 [SCA]
0019003A003E5A22E2337044D955066111F63B00
uid [ unknown] John Doe <jogn@doe.name>
sub elg1024 2018-02-28 [E]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}