using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cardType=([^&\s]*)";
string input = @"cardType=A&Return=True
cardType=AbC321
Return=False&cardType=C
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}