$re = '/cardType=([^&\s]*)/';
$str = 'cardType=A&Return=True
cardType=AbC321
Return=False&cardType=C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);