const regex = /\B('|")([^\W_]+)\1|\b(?:'|")[^\W_]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(\'|")([^\\W_]+)\\1|\\b(?:\'|")[^\\W_]+', 'g')
const str = `ali'den 'cevap'
ali'ten 'cevap'
ali'te 'cevap'`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);