import re
regex = re.compile(r"\B('|\")([^\W_]+)\1|\b(?:'|\")[^\W_]+")
test_str = ("ali'den 'cevap'\n"
"ali'ten 'cevap'\n"
"ali'te 'cevap'")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)