$re = '/\b(?:[a-z]*([a-z])[^a-z]+(?=\1))+[a-z]*/i';
$str = 'elementum magna sodales should match elementum magna, while something like Proin nunc curna, aliquet nec should return Proin nunc curna, aliquet, but an earring should return nothing because n is not the same as e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);