import re
regex = re.compile(r"\b(?:[a-z]*([a-z])[^a-z]+(?=\1))+[a-z]*", flags=re.IGNORECASE)
test_str = "elementum magna sodales should match elementum magna, while something like Proin nunc curna, aliquet nec should return Proin nunc curna, aliquet, but an earring should return nothing because n is not the same as e"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")