import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=^pow)\\(([^()]*|\\(([^()]*|\\([^()]*\\))*\\))*\\))";
final String string = "pow(y,2)\n"
+ "pow(y,2+2)\n"
+ "pow(y,2-3)\n"
+ "pow(y,2.2)\n"
+ "pow(y,(23)/(2))+23123\n"
+ "pow(y,pow(2,pow(2,4)))-932\n"
+ "pow(y,pow(2,1*pow(2,0.5)))+23\n\n"
+ "//Erro\n"
+ "pow(y,2)*pow(2,2)\n"
+ "pow(y,3)-pow(2,2)\n"
+ "pow(y,4)+pow(2,2)\n"
+ "pow(y,pow(2,1*pow(2,0.5)))+pow(1,1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}