import re
regex = re.compile(r"((?<=^pow)\(([^()]*|\(([^()]*|\([^()]*\))*\))*\))", flags=re.MULTILINE)
test_str = ("pow(y,2)\n"
"pow(y,2+2)\n"
"pow(y,2-3)\n"
"pow(y,2.2)\n"
"pow(y,(23)/(2))+23123\n"
"pow(y,pow(2,pow(2,4)))-932\n"
"pow(y,pow(2,1*pow(2,0.5)))+23\n\n"
"//Erro\n"
"pow(y,2)*pow(2,2)\n"
"pow(y,3)-pow(2,2)\n"
"pow(y,4)+pow(2,2)\n"
"pow(y,pow(2,1*pow(2,0.5)))+pow(1,1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")