re = /((?<=^pow)\(([^()]*|\(([^()]*|\([^()]*\))*\))*\))/m
str = 'pow(y,2)
pow(y,2+2)
pow(y,2-3)
pow(y,2.2)
pow(y,(23)/(2))+23123
pow(y,pow(2,pow(2,4)))-932
pow(y,pow(2,1*pow(2,0.5)))+23
//Erro
pow(y,2)*pow(2,2)
pow(y,3)-pow(2,2)
pow(y,4)+pow(2,2)
pow(y,pow(2,1*pow(2,0.5)))+pow(1,1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end