#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(?\d{2}\)?\s?\d{5}\-?\d{4}"
Local $sString = "11965453789" & @CRLF & _
"" & @CRLF & _
"(11)965453789" & @CRLF & _
"" & @CRLF & _
"(11) 965453789" & @CRLF & _
"" & @CRLF & _
"(11) 96545-3789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")