import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?\\d{2}\\)?\\s?\\d{5}\\-?\\d{4}";
final String string = "11965453789\n\n"
+ "(11)965453789\n\n"
+ "(11) 965453789\n\n"
+ "(11) 96545-3789";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}