using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"staging\.wpengine\.";
string input = @"https://tgdev.staging.wpengine.com
https://tgdev.wpengine.com
http://localhost
http://127.0.0.1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}