const regex = /staging\.wpengine\./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('staging\\.wpengine\\.', '')
const str = `https://tgdev.staging.wpengine.com
https://tgdev.wpengine.com
http://localhost
http://127.0.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}