$re = '/staging\.wpengine\./';
$str = 'https://tgdev.staging.wpengine.com
https://tgdev.wpengine.com
http://localhost
http://127.0.0.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);