$re = '`(?:<!\\\\)".*(?:<!\\\\)"`';
$str = 'Word "Two Words" Quo\\"te "Quo\\"ted Words"
asd bugina="as os" oqwr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);