re = /(?:<!\\)".*(?:<!\\)"/
str = 'Word "Two Words" Quo\\"te "Quo\\"ted Words"
asd bugina="as os" oqwr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end