using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
\G(?!\A)
|
{ (?=[^}]* })
|
\[ (?=[^]]* ])
)
\K
[A-G] [^]A-G}]*";
string input = @"{A''BsCb}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}