import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " \\G(?!\\A)\n"
+ " |\n"
+ " \\{ (?=[^\\}]* \\})\n"
+ " |\n"
+ " \\[ (?=[^]]* ])\n"
+ ")\n"
+ "\\K\n"
+ "[A-G] [^]A-G\\}]*";
final String string = "{A''BsCb}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}