package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
\G(?!\A)
|
{ (?=[^}]* })
|
\[ (?=[^]]* ])
)
\K
[A-G] [^]A-G}]*`)
var str = `{A''BsCb}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}