#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{({([^{}]*+(?:(?1)[^{}]*)*+)})}"
Local $sString = "{{ function(){ echo 1234; }; }}" & @CRLF & _
"" & @CRLF & _
"{{ function(){ " & @CRLF & _
"if (sblitch != slobtch) {" & @CRLF & _
" echo 1234;" & @CRLF & _
" }} }}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")