package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{({([^{}]*+(?:(?1)[^{}]*)*+)})}`)
var str = `{{ function(){ echo 1234; }; }}
{{ function(){
if (sblitch != slobtch) {
echo 1234;
}} }}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}