using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{({([^{}]*+(?:(?1)[^{}]*)*+)})}";
string input = @"{{ function(){ echo 1234; }; }}
{{ function(){
if (sblitch != slobtch) {
echo 1234;
}} }}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}