re = /{({([^{}]*+(?:(?1)[^{}]*)*+)})}/
str = '{{ function(){ echo 1234; }; }}
{{ function(){
if (sblitch != slobtch) {
echo 1234;
}} }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end