using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\(\""#.*\""\)\.click|\.load\(\"".*\""\);";
string input = @"$(document).ready(function(){
$(""#travel"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=1"");
});
$(""#lifestyle"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=2"");
});
$(""#fnb"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=3"");
});
$(""#gadget_entertainment"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=4"");
});
$(""#dailyneeds"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=5"");
});
$(""#others_promo"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=0&subcat=6"");
});
$(""#kartukredit"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=1"");
});
$(""#simpanan"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=2"");
});
$(""#others"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=3"");
});
$(""#ebanking"").click(function(){
$(""#contentpromolain2"").load(""ajax.promolainnya.php?product=4"");
});
});";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}