import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\(\\\"#.*\\\"\\)\\.click|\\.load\\(\\\".*\\\"\\);";
final String string = "$(document).ready(function(){\n\n"
+ " $(\"#travel\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=1\");\n"
+ " });\n\n"
+ " $(\"#lifestyle\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=2\");\n"
+ " });\n\n"
+ " $(\"#fnb\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=3\");\n"
+ " });\n\n"
+ " $(\"#gadget_entertainment\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=4\");\n"
+ " });\n\n"
+ " $(\"#dailyneeds\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=5\");\n"
+ " });\n\n"
+ " $(\"#others_promo\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=6\");\n"
+ " });\n\n"
+ " $(\"#kartukredit\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=1\");\n"
+ " });\n\n"
+ " $(\"#simpanan\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=2\");\n"
+ " });\n\n"
+ " $(\"#others\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=3\");\n"
+ " });\n\n"
+ " $(\"#ebanking\").click(function(){ \n"
+ " $(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=4\");\n"
+ " });\n"
+ "});";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}