// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"\$\(\"#.*\"\)\.click|\.load\(\".*\"\);"##).unwrap();
let string = "$(document).ready(function(){
$(\"#travel\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=1\");
});
$(\"#lifestyle\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=2\");
});
$(\"#fnb\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=3\");
});
$(\"#gadget_entertainment\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=4\");
});
$(\"#dailyneeds\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=5\");
});
$(\"#others_promo\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=0&subcat=6\");
});
$(\"#kartukredit\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=1\");
});
$(\"#simpanan\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=2\");
});
$(\"#others\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=3\");
});
$(\"#ebanking\").click(function(){
$(\"#contentpromolain2\").load(\"ajax.promolainnya.php?product=4\");
});
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}