const regex = /\$\(\"#.*\"\)\.click|\.load\(\".*\"\);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\(\\"#.*\\"\\)\\.click|\\.load\\(\\".*\\"\\);', 'g')
const str = `\$(document).ready(function(){
\$("#travel").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=1");
});
\$("#lifestyle").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=2");
});
\$("#fnb").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=3");
});
\$("#gadget_entertainment").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=4");
});
\$("#dailyneeds").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=5");
});
\$("#others_promo").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=0&subcat=6");
});
\$("#kartukredit").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=1");
});
\$("#simpanan").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=2");
});
\$("#others").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=3");
});
\$("#ebanking").click(function(){
\$("#contentpromolain2").load("ajax.promolainnya.php?product=4");
});
});`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}