const regex = /^(.*\..*)(\..*)(\..*)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\..*)(\\..*)(\\..*)$', 'gmi')
const str = `/image-server/image/sdfq433qmong0id.340x280.32442422435.jpeg
/image-server/image/amongo1d000000f.1024x680.34234082340823042.png
/image-server/image/amongo1d000000f.1024x680.1430829315.gif
/image-server/image/507c7f79bcf86cd7994f6c0e.1024x680.1430829315.ext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}