import re
regex = re.compile(r"^(.*\..*)(\..*)(\..*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/image-server/image/sdfq433qmong0id.340x280.32442422435.jpeg\n"
"/image-server/image/amongo1d000000f.1024x680.34234082340823042.png\n"
"/image-server/image/amongo1d000000f.1024x680.1430829315.gif\n"
"/image-server/image/507c7f79bcf86cd7994f6c0e.1024x680.1430829315.ext")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")