// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(.*\..*)(\..*)(\..*)$").unwrap();
let string = "/image-server/image/sdfq433qmong0id.340x280.32442422435.jpeg
/image-server/image/amongo1d000000f.1024x680.34234082340823042.png
/image-server/image/amongo1d000000f.1024x680.1430829315.gif
/image-server/image/507c7f79bcf86cd7994f6c0e.1024x680.1430829315.ext";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}