$re = '/^(.*\..*)(\..*)(\..*)$/mi';
$str = '/image-server/image/sdfq433qmong0id.340x280.32442422435.jpeg
/image-server/image/amongo1d000000f.1024x680.34234082340823042.png
/image-server/image/amongo1d000000f.1024x680.1430829315.gif
/image-server/image/507c7f79bcf86cd7994f6c0e.1024x680.1430829315.ext';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);