# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12})$/$1/gim;t' <<< "f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f"