package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12})$`)
var str = `f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}