re = /^([0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12})$/im
str = 'f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result