import re
regex = re.compile(r"^([0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12})$", flags=re.IGNORECASE | re.MULTILINE)
test_str = "f27a5b7f-0b7c-4e79-aff5-bdb0d34f3a9f"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)