import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(a)(?=(?:.*(b))?)(?=(?:.*(c))?)(?=(?:.*(d))?)";
final String string = "a\n"
+ "a b\n"
+ "a c\n"
+ "a b c\n"
+ "a c b\n"
+ "a b c d\n"
+ "a d b c\n"
+ "a c d b";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}