$re = '/(a)(?=(?:.*(b))?)(?=(?:.*(c))?)(?=(?:.*(d))?)/';
$str = 'a
a b
a c
a b c
a c b
a b c d
a d b c
a c d b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);