import re
regex = re.compile(r"(a)(?=(?:.*(b))?)(?=(?:.*(c))?)(?=(?:.*(d))?)")
test_str = ("a\n"
"a b\n"
"a c\n"
"a b c\n"
"a c b\n"
"a b c d\n"
"a d b c\n"
"a c d b")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")